Back to overview
Degraded

Statement from WetRentals Regarding Recent Security Incident

Jul 27 at 04:01pm EDT
Affected services
Web Application

Resolved
Jul 27 at 04:45pm EDT

Status Update from WetRentals

We want to update you on the recent security incident involving our payment processing system. Stripe's specialist team is currently investigating the situation, and we have received confirmation that there is no risk to customer data.

Key points:

  • Customer Data Security: Stripe has verified that no customer information has been compromised.

  • Service Status: All services are running normally, and there is no disruption to our operations.

  • Ongoing Review: We are actively reviewing the incident to ensure all fraudulent charges are addressed and reversed.

We appreciate your patience and continued support. If you have any questions or concerns, please contact our support team at support@wetrentals.com.

Thank you for your understanding. All systems are operational.

Sincerely,
The WetRentals Team

Created
Jul 27 at 04:01pm EDT

At WetRentals, safeguarding your information is our top priority. We are aware of a recent security incident involving multiple unauthorized attempts to process small transactions on our Stripe account.

We want to assure our customers that no personal or payment information has been compromised. Our security systems have been activated, and we have taken immediate action to secure our accounts and prevent any further unauthorized access.

We are currently investigating the cause of this incident and are working closely with our payment processing partner, Stripe, to ensure that all aspects of our security protocols are robust and effective.

Your trust is incredibly important to us, and we are committed to keeping you informed as we continue to enhance our security measures. If you have any questions or concerns, please do not hesitate to reach out to our customer support team.

Thank you for your understanding and continued support.

Sincerely,
The WetRentals Team