Back to overview

Currency Issue

Apr 29 at 11:05am EDT
Affected services
Web Application

Resolved
Apr 29 at 11:05am EDT

We are aware of an issue with currency defaulting to USD. We are actively looking at a solution.

Resolved. All transactions will be refunded the difference as needed.